6 # dh-make output file, you may use that output file without restriction. |
6 # dh-make output file, you may use that output file without restriction. |
7 # This special exception was added by Craig Small in version 0.37 of dh-make. |
7 # This special exception was added by Craig Small in version 0.37 of dh-make. |
8 |
8 |
9 # Uncomment this to turn on verbose mode. |
9 # Uncomment this to turn on verbose mode. |
10 #export DH_VERBOSE=1 |
10 #export DH_VERBOSE=1 |
11 |
|
12 |
|
13 |
|
14 |
|
15 |
11 |
16 configure: configure-stamp |
12 configure: configure-stamp |
17 configure-stamp: |
13 configure-stamp: |
18 dh_testdir |
14 dh_testdir |
19 # Add here commands to configure the package. |
15 # Add here commands to configure the package. |
25 |
21 |
26 build-stamp: configure-stamp |
22 build-stamp: configure-stamp |
27 dh_testdir |
23 dh_testdir |
28 |
24 |
29 # Add here commands to compile the package. |
25 # Add here commands to compile the package. |
30 $(MAKE) |
|
31 #docbook-to-man debian/mercurial-server.sgml > mercurial-server.1 |
26 #docbook-to-man debian/mercurial-server.sgml > mercurial-server.1 |
32 |
27 |
33 touch $@ |
28 touch $@ |
34 |
29 |
35 clean: |
30 clean: |
36 dh_testdir |
31 dh_testdir |
37 dh_testroot |
32 dh_testroot |
38 rm -f build-stamp configure-stamp |
33 rm -f build-stamp configure-stamp |
39 |
34 |
40 # Add here commands to clean up after the build process. |
35 # Add here commands to clean up after the build process. |
41 $(MAKE) clean |
|
42 |
36 |
43 dh_clean |
37 dh_clean |
44 |
38 |
45 install: build |
39 install: build |
46 dh_testdir |
40 dh_testdir |
47 dh_testroot |
41 dh_testroot |
48 dh_clean -k |
42 dh_clean -k |
49 dh_installdirs |
43 dh_installdirs |
50 |
44 |
51 # Add here commands to install the package into debian/mercurial-server. |
45 # Add here commands to install the package into debian/mercurial-server. |
52 $(MAKE) DESTDIR=$(CURDIR)/debian/mercurial-server install |
46 cp \ |
53 |
47 src/hg-ssh \ |
|
48 src/refresh-auth \ |
|
49 debian/mercurial-server/usr/share/mercurial-server |
|
50 cp \ |
|
51 src/mercurialserver/__init__.py \ |
|
52 src/mercurialserver/paths.py \ |
|
53 src/mercurialserver/changes.py \ |
|
54 src/mercurialserver/access.py \ |
|
55 src/mercurialserver/servelog.py \ |
|
56 src/mercurialserver/refreshauth.py \ |
|
57 src/mercurialserver/ruleset.py \ |
|
58 debian/mercurial-server/usr/share/mercurial-server/mercurialserver |
|
59 cp \ |
|
60 src/init/hginit \ |
|
61 src/init/hgadmin-hgrc \ |
|
62 debian/mercurial-server/usr/share/mercurial-server/init |
|
63 cp \ |
|
64 src/init/conf/remote-hgrc \ |
|
65 src/init/conf/access.conf \ |
|
66 debian/mercurial-server/etc/mercurial-server |
54 |
67 |
55 # Build architecture-independent files here. |
68 # Build architecture-independent files here. |
56 binary-indep: build install |
69 binary-indep: build install |
57 # We have nothing to do by default. |
70 # We have nothing to do by default. |
58 |
71 |
59 # Build architecture-dependent files here. |
72 # Build architecture-dependent files here. |
60 binary-arch: build install |
73 binary-arch: build install |
61 dh_testdir |
74 dh_testdir |
62 dh_testroot |
75 dh_testroot |
63 dh_installchangelogs |
76 # dh_installchangelogs |
64 dh_installdocs |
77 dh_installdocs |
65 dh_installexamples |
78 # dh_installexamples |
66 # dh_install |
79 # dh_install |
67 # dh_installmenu |
80 # dh_installmenu |
68 # dh_installdebconf |
81 # dh_installdebconf |
69 # dh_installlogrotate |
82 # dh_installlogrotate |
70 # dh_installemacsen |
83 # dh_installemacsen |