debian/rules
author Paul Crowley <paul@lshift.net>
Tue, 13 Oct 2009 18:21:22 +0100
branchdebian
changeset 116 d99f3169828a
parent 99 e99262dfa950
child 172 5dd3698fad54
permissions -rwxr-xr-x
Looks like the start of a working Debianization

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

configure: configure-stamp
configure-stamp:
	dh_testdir
	# Add here commands to configure the package.

	touch configure-stamp


build: build-stamp

build-stamp: configure-stamp  
	dh_testdir

	# Add here commands to compile the package.
	#docbook-to-man debian/mercurial-server.sgml > mercurial-server.1

	touch $@

clean: 
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp

	# Add here commands to clean up after the build process.

	dh_clean 

install: build
	dh_testdir
	dh_testroot
	dh_clean -k 
	dh_installdirs

	# Add here commands to install the package into debian/mercurial-server.
	cp \
	    src/hg-ssh \
	    src/refresh-auth \
	    debian/mercurial-server/usr/share/mercurial-server
	cp \
	    src/mercurialserver/__init__.py \
	    src/mercurialserver/paths.py \
	    src/mercurialserver/changes.py \
	    src/mercurialserver/access.py \
	    src/mercurialserver/servelog.py \
	    src/mercurialserver/refreshauth.py \
	    src/mercurialserver/ruleset.py \
	    debian/mercurial-server/usr/share/mercurial-server/mercurialserver
	cp \
	    src/init/hginit \
	    src/init/hgadmin-hgrc \
	    debian/mercurial-server/usr/share/mercurial-server/init
	cp \
	    src/init/conf/remote-hgrc \
	    src/init/conf/access.conf \
	    debian/mercurial-server/etc/mercurial-server

# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.

# Build architecture-dependent files here.
binary-arch: build install
	dh_testdir
	dh_testroot
#	dh_installchangelogs 
	dh_installdocs
#	dh_installexamples
#	dh_install
#	dh_installmenu
#	dh_installdebconf	
#	dh_installlogrotate
#	dh_installemacsen
#	dh_installpam
#	dh_installmime
#	dh_python
#	dh_installinit
#	dh_installcron
#	dh_installinfo
#	dh_installman
#	dh_link
#	dh_strip
#	dh_compress
	dh_fixperms
#	dh_perl
#	dh_makeshlibs
	dh_installdeb
#	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure