debian/rules
branchdebian
changeset 189 56910e62871a
parent 188 ee1117771e12
child 204 d46ef29ab17a
equal deleted inserted replaced
188:ee1117771e12 189:56910e62871a
     1 #!/usr/bin/make -f
     1 #!/usr/bin/make -f
     2 # -*- makefile -*-
     2 %:
     3 # Sample debian/rules that uses debhelper.
     3 	dh $@
     4 # This file was originally written by Joey Hess and Craig Small.
       
     5 # As a special exception, when this file is copied by dh-make into a
       
     6 # dh-make output file, you may use that output file without restriction.
       
     7 # This special exception was added by Craig Small in version 0.37 of dh-make.
       
     8 
     4 
     9 # Uncomment this to turn on verbose mode.
     5 override_dh_auto_install:
    10 #export DH_VERBOSE=1
       
    11 
       
    12 configure: configure-stamp
       
    13 configure-stamp:
       
    14 	dh_testdir
       
    15 	# Add here commands to configure the package.
       
    16 
       
    17 	touch configure-stamp
       
    18 
       
    19 build: build-stamp
       
    20 
       
    21 build-stamp: configure-stamp  
       
    22 	dh_testdir
       
    23 
       
    24 	# Add here commands to compile the package.
       
    25 	#docbook-to-man debian/mercurial-server.sgml > mercurial-server.1
       
    26 
       
    27 	touch $@
       
    28 
       
    29 clean: 
       
    30 	dh_testdir
       
    31 	dh_testroot
       
    32 	rm -f build-stamp configure-stamp
       
    33 
       
    34 	# Add here commands to clean up after the build process.
       
    35 
       
    36 	dh_clean 
       
    37 
       
    38 install: build
       
    39 	dh_testdir
       
    40 	dh_testroot
       
    41 	dh_clean -k 
       
    42 	dh_installdirs
       
    43 
       
    44 	# Add here commands to install the package into debian/mercurial-server.
       
    45 	$(MAKE) installfiles \
     6 	$(MAKE) installfiles \
    46 	    TOPDIR=debian/mercurial-server \
     7 	    TOPDIR=debian/mercurial-server \
    47 	    PREFIX=debian/mercurial-server/usr/share
     8 	    PREFIX=debian/mercurial-server/usr/share
    48 
     9 
    49 # Build architecture-independent files here.
    10 override_dh_pysupport:
    50 binary-indep: build install
    11 	dh_pysupport /usr/share/mercurial-server/mercurialserver
    51 # We have nothing to do by default.
       
    52 
    12 
    53 # Build architecture-dependent files here.
       
    54 binary-arch: build install
       
    55 	dh_testdir
       
    56 	dh_testroot
       
    57 	dh_installchangelogs 
       
    58 	dh_installdocs
       
    59 #	dh_installexamples
       
    60 #	dh_install
       
    61 #	dh_installmenu
       
    62 #	dh_installdebconf	
       
    63 #	dh_installlogrotate
       
    64 #	dh_installemacsen
       
    65 #	dh_installpam
       
    66 #	dh_installmime
       
    67 	dh_pysupport /usr/share/mercurial-server/mercurialserver
       
    68 #	dh_installinit
       
    69 #	dh_installcron
       
    70 #	dh_installinfo
       
    71 #	dh_installman
       
    72 #	dh_link
       
    73 #	dh_strip
       
    74 	dh_compress
       
    75 	dh_fixperms
       
    76 #	dh_perl
       
    77 #	dh_makeshlibs
       
    78 	dh_installdeb
       
    79 #	dh_shlibdeps
       
    80 	dh_gencontrol
       
    81 	dh_md5sums
       
    82 	dh_builddeb
       
    83 
       
    84 binary: binary-indep binary-arch
       
    85 .PHONY: build clean binary-indep binary-arch binary install configure